Friday, June 26, 2009

Secunia Personal Software Inspector version 1.5 Released

Version 1.5 of Secunia's Personal Software Inspector (PSI) update tool for Microsoft Windows aims to provide assistance in this respect, offering a dedicated section on "Secure Browsing". The "Secure Browsing" feature gives users an overview of whether important components like the Flash plug-ins, Java or browser libraries are vulnerable and in need of an update, although the overview is only displayed once users switch from "Simple" to "Advanced" mode.

In a first test on the Windows 7 release candidate, PSI pointed out vulnerable XML libraries for Internet Explorer 7 and 8 and recommended an update – even though the software was current. On a sparsely maintained Vista system, PSI recommended that none of the installed browsers should be used, because both the browsers and their plug-ins contained critical vulnerabilities.



No comments: